Mac-TV.de

Mac-TV.de (https://www.mac-tv.de/Forum/index.php)
-   Macs, macOS und Zubehör (https://www.mac-tv.de/Forum/forumdisplay.php?f=30)
-   -   Webseiten laden extrem langsam (https://www.mac-tv.de/Forum/showthread.php?t=3217)

deedee 01.11.2008 15:12

Webseiten laden extrem langsam
 
Hallo liebe Community,
ich bräuchte mal wieder eure Hilfe :-)

Zur Ausgangssituation:
Ich habe bei zwei unterschiedlichen Hostern (strato und all-inkl) jeweils eine Website mithilfe von WordPress realisiert.

Mir ist aufgefallen, dass beide Seiten extrem langsam laden. Ich habe mir mithilfe des Webkits unter den Developer-Einstellungen die Webinformationen anzeigen lassen. Dort fällt auf, dass die Datei "neu" erst nach ca. 2,5 Sekunden beginnt zu reagieren. Alle anderen Dateien (Stylesheets, Scripte, Bilder usw.) beginnen erst danach ebenfalls zu laden aber das dann in einer adäquaten Geschwindigkeit. Dies lässt sich beliebig reproduzieren. Die erste Reaktion beginnt immer erst nach ungefähr 2 - 3 Sekunden.


Liegt es an der Datenbankabfrage? Eigentlich kann es doch nicht sein, da die WordPress Installationen ja unabhängig von einander auf zwei verschiedenen Servern bei unterschiedlichen Hostern liegen.

Das Phänomen habe ich auch bei dem Blog http://www.schimanke.org/ beobachtet. Er betreibt seinen Blog auch mit WordPress. Es scheint also irgendwie an WordPress zu liegen, wobei es bei nareharos Blog ;-) wunderbar fix läuft.

Hat jemand eine Ahnung woran das liegen könnte?

deedee 06.11.2008 18:42

Hat wirklich niemand eine Ahnung? Böttöööö :-D

EDIT: @nareharo:
Wieso das denn? Ich bin doch nicht als Prügelknabe oder aggressiver Zeitgenosse hier bekannt, oder doch? :-/ Sollte ich ein völlig falsches Bild von mir selbst haben :-)

n4r3H4r0 06.11.2008 18:53

Armer deedee :-o :-(

Ich glaube die haben alle Angst was falsches zu posten.

mdmtv 06.11.2008 18:59

Ich finde dieses Verhalten nicht soo ungewöhnlich, Performance-Probleme sind beim Shared-Hosting ja eigentlich immer vorprogrammiert.
Sofern sich die Performance-Einbusse immer nur auf die erste Seite bezieht, könnte das schlicht die Ursache haben, dass die Maschine swappt und seinen Arbeitsspeicher auslagert. Da liegt halt dann die Datenbank und der spezifische Teil des Webservers auf der Festplatte und wird nachgeladen. Wenn's denn erstmal "da" ist, flutscht es. Finde ich jetzt nicht soo ungewöhnlich, das beobachtet man beim Shared Hosting eigentlich öfter.

Gruß,
Sönke

Furcas 06.11.2008 19:12

habe ja auch einen Wordpress Blog und der braucht recht lange zum laden. Aber ein solch große Latenz hab ich nicht.
Sind ca. 800ms obwohl das laden der kompletten Seite bis zu 8 Sekunden dauern kann, was aber an anderen Sachen wie Videos von Myspace & Scripten liegt.

deedee 06.11.2008 19:13

Die Performance-Einbuße bezieht sich auf alle (Unter-)Seiten.
Wieso liegt das denn am Shared-Hosting? Die Hoster haben doch nichts mit einander zu tun. Und die Seiten sind auch getrennt von einander. Eine dritte Seite von mir (ohne WordPress Installation) lädt rasend schnell.
Also liegt's an der Datenbankabfrage und der Methode, wohin die Hoster sie auslagern? Habe ich das richtig verstanden? :-)

mdmtv 06.11.2008 20:01

Zitat:

Zitat von deedee (Beitrag 41572)
Also liegt's an der Datenbankabfrage und der Methode, wohin die Hoster sie auslagern? Habe ich das richtig verstanden? :-)

Auch die Datenbank wird geteilt. Mit "Seiten" hat das erstmal nichts zu tun, das sharing findet viel weiter "unten" statt.

Gruß,
Sönke

deedee 06.11.2008 20:11

Ah, ok. Das wusste ich nicht. Kann man das irgendwie beeinflussen oder einstellen, dass dieses sharing nicht stattfindet und die Datenbankabfrage schneller geht?

mdmtv 06.11.2008 21:35

Zitat:

Zitat von deedee (Beitrag 41589)
Ah, ok. Das wusste ich nicht. Kann man das irgendwie beeinflussen oder einstellen, dass dieses sharing nicht stattfindet und die Datenbankabfrage schneller geht?

Nein, das geht nicht. Beim shared Hosting teilen sich halt locker 100 Leute (abhängig vom Tarif) einen Rechner. Also alles. Datenbank, Webserver, Speicher, Festplatte etc. Der Speicherbereich und die CPU-Leistung, die einem da zur Verfügung stehen, sind im Worst case (alle Auftritte brennen) minimal.
Das ist von mir alles natürlich nur eine Annahme, die Problembeschreibung ist jedoch typisch für relativ günstigen Webspace. You get what you pay for.
Abhilfe schafft da i.d.R. nur ein Wechsel in ein teureres Paket (wobei auch das fraglich sein kann), zu einem virtuellen Server oder sogar einen dedicated Server.
Ich hatte mal ein recht komplexes phpBB für eine geschlossene Kommilitonengruppe aufgesetzt. Katastrophe. Mal supergut, manchmal 10-15 Sek. Wartezeit, bis sich das Forum aufgebaut hatte. Für EUR 5,-- im Monat stellt halt einem niemand 'nen Dual Core hin. ;-) Seit dem nur noch dedicated und sie Sache läuft wie am Schnürchen.

Gruß,
Sönke

deedee 09.11.2008 13:43

Ich danke euch für eure Kommentare. Ihr habt mir echt weitergeholfen. Danke sehr :-)


Alle Zeitangaben in WEZ +2. Es ist jetzt 13:09 Uhr.

Powered by vBulletin® Version 3.6.8 (Deutsch)
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.